Reset Theme error

Jul 11, 2008 at 4:38 PM
Hello Everyone,

I've installed and deployed the Reset Theme solution into my sharepoint site collection but when I selected reset collection theme, I get this error:

c:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\LAYOUTS\FABFeatures\ThemeSetterCollection.aspx(85): error CS0117: 'ASP._layouts_fabfeatures_themesettercollection_aspx' does not contain a definition for 'HyperLinkSiteSettings'   at System.Web.Compilation.AssemblyBuilder.Compile()
   at System.Web.Compilation.BuildProvidersCompiler.PerformBuild()
   at System.Web.Compilation.BuildManager.CompileWebFile(VirtualPath virtualPath)
   at System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)
   at System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)
   at System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean noAssert)
   at System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp, Boolean noAssert)
   at System.Web.UI.PageHandlerFactory.GetHandlerHelper(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath)
   at System.Web.UI.PageHandlerFactory.System.Web.IHttpHandlerFactory2.GetHandler(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath)
   at System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, VirtualPath path, String pathTranslated, Boolean useAppConfig)
   at System.Web.HttpApplication.MapHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)


Any ideas?
Aug 7, 2008 at 8:53 PM
I get the same error since I upgraded to WSS SP1, post SP1, with some language packs.

This happens with the first release and with v1[1].2

I would really appreciate any help on this.

Thanks!
Aug 12, 2008 at 6:32 PM
Hi all,
Sorry for the time :)

I find the error in the aspx file :
  • C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\LAYOUTS\FABFeatures\ThemeSetterCollection.aspx

You can delete the two lines 85 and 86.

I change the file abd recreate a new version of the WSP file.

Sorry for this error.

Romelard Fabrice [MVP]

Aug 26, 2008 at 3:54 AM

Hi All,

I couldn´t try this feature because I have a "Unknown error" when I want to activate "Reset Collection Theme" menu opcion from Site Collection Administration
I've deleted 85 and 86 code lines. They are ...  

this.HyperLinkSiteSettings.Text = "Return to the Site Settings";
this.HyperLinkSiteSettings.NavigateUrl = myNewWeb.Url + "/_layouts/settings.aspx";

Any help would be greatly appreciated

Thanks,

 

Aug 26, 2008 at 12:33 PM
Hi Pablor,
It's difficult to know why you have this error without more information.
This feature is only a new link added in the site collection admin, and not create or copy anything.
You can test the link from your collection :
 - http://yourserverfarm/sites/yourcollection/_layouts/FABFeatures/ThemeSetterCollection.aspx

Best regards
Fabrice Romelard